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Introduction

Simulation Program with Integrated Circuit Emphasis (SPICE) was originally devel-
oped at the Electronics Research Laboratory of the University of California, Berkeley in
1975 by Larry Nagel and Donald Pederson [1]. Various free and commercial versions of
SPICE simulators are among the most important tools behind the success of the whole
electronic industry. SPICE simulations help the engineers to build faster and more
powerful computers, which in turn expand the capabilities of the simulator handling
more complex circuit models. Among the commercial SPICE simulators, Star-HSPICE
[2][3] is the most widely adopted by the electrical and electronic engineers. It is touted
as “The Gold Standard for Accurate Circuit Simulation.” A SPICE simulation can
generate lots of data for a given a circuit. Depending on the complexity and accuracy
requirement, the voltage, current, and other circuit parameters can amount to a huge
number. Saving the simulation results in binary format can save significant storage (file
size on hard disk) compared to saving in text format. However, unlike a text file, the
format of a binary file is difficult to decipher. The key for writing an HSPICE viewer

is the knowledge of the patterns and rules of those binary files. The maker of HSPICE,
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Synopsis, provides waveform viewers Avanwave, and Cosmos Scope. Sandwork sells a
HSPICE viewer called SPICE Explorer. The Gnu gEDA project provides a waveform
viewer, gWave on Linux and Mac platforms, which is able to read HSPICE binary files.
Micro Magic markets a SUE Design Manager, which contains a waveform viewer called
new spice tools (nst). Another commercial HSPICE waveform viewer called KOALA
is available from Luminis Pty. Ltd. and The University of Adelaide. A free HSPICE
waveform viewer, called HSPICE Toolbox, using Matlab can be downloaded from MIT
High Speed Circuits and Systems Group including some source codes. The HSPICE
viewer presented here is developed based the MIT code plus additional knowledge ex-
tracted from analyzing many example files.

Some useful URLs are listed below:

Synopsis HSPICE:

http://www.synopsys.com/products/mixedsignal /hspice /hspice.html.

Sandwork Spice Explorer:

http://www.sandwork.com /products_spice.htm.

gEDA gWave:

http://www.geda.seul.org/tools/gwave/index.html.

Macro Magic SUE:

http://www.micromagic.com/tools/sue_datasheet.html.
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Luminis Pty. Ltd. and The University of Adelaide KOALA:

http://www.eleceng.adelaide.edu.au/Koala/.

MIT High Speed Circuits and Systems Group:

http://www-mtl.mit.edu/researchgroups/perrottgroup/tools.html.

Remark 1 Since HS-View assumes the set of rules based on a trial-and-error approach,
chances are, some HSPICE files might be either incorrectly interpreted or totally un-

recognizable.

0.1 Features of this tool

e Read HSPICE .tr* and .ac* files.

e Display list of variables saved in each file.

e Accommodate additional sweep parameters.

¢ Plot time-domain waveform with option of eye diagram generation.

* Plot frequency-domain variables filtered by the (magnitude, phase, db, real or

imag) function.
e Export plots to vector-based graphic formats (EPS and SVG)

e Export plot data to ACSII files
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Acknowledgement

e HSPICE Viewer is written 100% in Java.

e The following Java numerical packages are instrumental building blocks:

— JFreechart: a comprehensive plotting package. URL: http://www.jfree.org

PtPlot: A plotting package as a part of the Ptolemy at UC Berkeley. URL:

http://ptolemy.berkeley.edu/java/ptplot/

Colt: a free Java toolkit at CERN for high performance computing. URL:

http://dsd.1bl.gov/ hoschek/colt/

JAMA (JAva MAtrix package): containss common matrix routines. URL:

http://math.nist.gov/javanumerics/jama/

— Jampack (JAva Matrix PACKage): matrix solver for complex matrices.

URL: ftp://math.nist.gov/pub/Jampack/Jampack/AboutJampack.html



CHAPTER 1 — MANUSCRIPT

e This document is prepared with LaTeX
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1.1 Installation

The installer is distributed as a jar file (say install. HSV1.0.jar), which should run on
any system with support of JavaTM (at least version 1.5). In modern operating system
like Windows XP, a double click should cause the installer to be launched automatically.
If not, user may open a prompt window, change directory to the location where the
installer resides, and type

java —jar install_.HSV1.0.jar

The above command should also apply to any UNIX/Linux or Mac OS-X
system. After successful installation, there is a uninstall directory under the main
application directory. The jar file there can be used to remove the installed files, when
desired.

After installation, user need to add a shortcut to the desktop, which points
to the file named HSV.bat in the application directory. Each time, the program can be
launched through this shortcut.

Note: This application requires support of JDK1.5 or higher.
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The Main User Interface

The main graphic interface provides controls by the user through elements such as lists

and buttons inside the main GUI panel area, and the menu items.

2.1 Parts of the Main GUI Panel Area

There are four portions, as shown in Figure 2.1, inside the panel area labeled “Data
Module”, “Variables”, “Value Filter”, and “Plot Components”. Each portion consists

of a list and some buttons. Functions of these elements are described below:

2.1.1 Data Module

The upper part of this portion is a list. Each time, when a new HSPICE dataset is

read from a file, a new data module will be added to the list, with name derived from
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Delete Plot all

Figure 2.1: The main application window.

the original data file. E.g., a file named “D:\temp\test1.tr0” will cause a data module
“testl” to be added to the list, once the file is successfully loaded through the File:

Open menu.

e Button “Rename”: can be used to change the name of the data module, provided

a module in the list is selected.

e Button “Delete All”: can be used to delete all data modules.

e Button “Delete”: can be used to remove a selected data module.

2.1.2 Variables

The upper list part will display all the circuit variables from the selected data module.
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2.1.3 Value Filter

In general, the frequency-domain variables are complex-valued. Often, the real-valued
plots are preferred. The list provides the choices of filters (or functions) that convert
complex values to real values. The name “Real”, “Imag”, “dB”, “Magnitude” and
“Phase” are self-explanatory. On the other hand, time-domain results are all real-

valued, hence the (no change) filter should be selected.

e Button “Add to plot”: is used to add a selected (Data Module):(Parameter):(Value

Filter) sequence to the next plot being prepared.

2.1.4 Plot Components

This part provides the necessary controls of composing a new plot.

e Button “Delete”: is used to delete the selected sequence.
e Button “Delete All”: is used to remove all sequences in the current list.

e Button “Plot All”: causes a new plot to be generated. Once a new plot is gener-
ated, it is beyond the control of the main GUI window. Please consult the section

on the “The Plotter Modules” for further information.

Once a plot is created, there are further manupulations available. Currently,
a plot can be generated with either JFreeChart or PtPlot package. More details about

plot manipulations are given in the next chapter.
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Plotting Utilities

3.1 Plotting Utility based on JFreeChart

In the standard JFreeChart distribution, there are certain built-in features for plot
manipulations. Among the choices of several plotting packages, mainly the XY data
plotting package is used in EE Circle tools. Enhancements are made to address the need
of various types of waveform display. Special efforts are made, based on the JFreeChart

API, to produce publication quality graphic files.

3.1.1 Features Come with JFreeChart

With a right mouse click on any part of the plot, a pop-up menu will be displayed

(Figure 3.1). It contains the following menu items:
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Figure 3.1: Upon a right mouse click anywhere on the plot, a pop-up menu appears.

Properties: allows the user to configure many aspects of the plot properties.

Save As: allows the current plot to be saved in PNG format.

Print: allows the current plot to be sent to the printer.

Zoom In: allows zooming into either or both axes.

Zoom Qut: allows zooming out of either or both axes.

Auto Range: automatically sets the plotting ranges.
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Figure 3.2: The “Title” tab associated with the “Properties” pop-up menu item.

Pop-up Menu “Properties”

Once the “Properties” menu is selected, a dialog will be displayed. The dialog contains

three tabbed panes: (1) Title, (2) Plot, and (3) Other.

The “Title” Pane As shown in Figure 3.2, this allows the user to change the title

of the plot, including its font style and color.
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Figure 3.3: The “Plot” tab associated with the “Properties” pop-up menu item.

The “Plot” Pane As shown in Figure 3.3, this pane gives controls to the

labels of the X (domain) axis and the Y (range) axis. Also, user can change the bounds

of the two axes.
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Figure 3.4: The “Other” tab associated with the “Properties” pop-up menu item.

The “Other” Pane The “Other” pane, as shown in Figure 3.4 gives

additional controls over the plot attributes like background color, series and stroke

colors.
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Figure 3.5: The “Print” pop-up menu item.

Pop-up Menu “Print”

The plot can be rendered to a printer with this dialog as shown in Figure 3.5.
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Figure 3.6: The “Zoom in” pop-up memu item.

{1 Properties...

Save as...

Print...

Zoom In b
Loom Out ¥ Both Axes

Auto Range *| Domain AXis

Range Axis

Figure 3.7: The “Zoom out” pop-up memu item.

Pop-up Menu “Zoom In”

As shown in Figure 3.6, the plot can be zoomed in either X/Y or both axes.

Pop-up Menu “Zoom Out”

As shown in Figure 3.7, the plot can be zoomed out in either X/Y or both axes.
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Figure 3.8: The “Auto Range” pop-up memu item.

Pop-up Menu “Auto Range”

Fither the X or the Y axis, or both axes can be automatically adjusted to fit all data

points.
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Figure 3.9: A typical plot window.
3.1.2 GUI Features added by EE Circle

Additional GUI elements implemented are organized by regular menus. As shown in
Figure 3.9, there are four menus on the menu bar: (1) File, (2) Plot Control, (3) Eye

Mode, and (4) Window.
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Figure 3.10: The “File” menu of a plot.

The “File” Menu

As shown in Figure 3.10, the “File” menu have the following items:

e New: the current plot will be cleared. All data will be reset.

e Delimiter: allows the user to set/change the delimiter (token separator) used

for reading/writing text data files.

e Scaling: allow user to define a scaling factor for X or Y data. For instance, if
X-factor is set to 1le6, a sequence of x-values like {2.0e6, 3.0e6, 4.0e6, 5.0e6} will

be converted into {2.0, 3.0, 4.0, 5.0} after imported from a file.

e Import X Y Data: Any text data file in form of (X Y) or (X Y1 Y2 ...) can

be imported.

e Save Plot as: generate scalable or raster graphics files.
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Figure 3.11: The “Delimiter” item under the “File” menu of a plot.

e Export XY Data: save the data within the current plot into text file.

e Close: close the plot window.

The “Delimiter” Menu Item As shown in Figure 3.11, this allows the user to

conveniently choose a delimiter (column separator) for use with a text data file.

The “Scaling” Menu Item As shown in Figure 3.12, user is given the opportunity
of setting the scaling factors for X/Y data. Once ‘X Factor’ or ‘Y Factor’ is chosen, a

pop-up dialog will be displayed to receive a new scaling factor value.
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File
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Figure 3.12: The “Scaling” item under the “File” menu of a plot.

The “Save Plot as” Menu Item As shown in Figure 3.13, there are three possible

graphic file formats supported:

e SVG: scalar vector graphics format. This is the most accurate representation of

the plot.

e PNG: portable network graphics format. This is a bit-mapped image format

that employs lossless data compression.

e JPG: This is the most popular raster format of graphics.

Remark 2 For user in need of the publication quality plots, it is highly recommended
to install an open source tool called Inkscape (http://www.inkscape.org/). Inkscape can

edit SVG file and export EPS file.
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File
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Close JPG

Figure 3.13: The “Save Plot as” item under the “File” menu of a plot.

The “Plot Control” Menu

As shown in Figure 3.14, there are the following menu items:

X-Grid: The radio button toggled on/off to turn on the grid lines for X axis.

Y-Grid: The radio button toggled on/off to turn on the grid lines for X axis.

Log-X: The radio button toggled on/off to turn on the logrithmic axis for X.

Log-Y: The radio button toggled on/off to turn on the logrithmic axis for Y.

X NumPFormat: defines a number format for X-axis labels.

Y NumFormat: defines a number format for Y-axis labels.

X Bounds: sets the minimum, maximum and increment for X-axis.

Y Bounds: sets the minimum, maximum and increment for Y-axis.
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Plot Control
2 ¥-Grid
2 Y-Grid

2 Liog-X
2 Liog-Y

¥ HumFormat
¥ HumFormeat

¥ Bounils
¥ Bounds

1 ® Show Legend
Legend Position »

curves

Figure 3.14: The “Plot Control” menu of a plot.

e Show Legend: legend can be turned on/off.

e Legend Position: legend placed at Right, Bottom, Left or Top of the plot.

e Curves: finer controls of the attributes of the curves.
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[Malog for new value
Specify number formatter
#0.0 |
OK Cancel

Figure 3.15: The pop-up dialog triggered by the “X NumFormat” item in the “Plot

Control” menu.

X/Y Number Format When either “X NumFormat” or “Y NumFormat” is se-

lected, a dialog similar to Figure 3.15 will be displayed.

A DecimalFormat pattern contains a positive and negative subpattern, for
example, " #,#4#0.00;(#,#+0.00)”. Each subpattern has a prefix, numeric part, and
suffix. The negative subpattern is optional; if absent, then the positive subpattern
prefixed with the localized minus sign (code>’-" in most locales) is used as the negative
subpattern. That is, 70.00” alone is equivalent to ”70.00;-0.00”. If there is an explicit
negative subpattern, it serves only to specify the negative prefix and suffix; the number
of digits, minimal digits, and other characteristics are all the same as the positive
pattern. That means that ”#,##0.0#;(#)” produces precisely the same behavior as
" # #H#0.04; (#,##0.04)”.

The prefixes, suffixes, and various symbols used for infinity, digits, thousands

separators, decimal separators, etc. may be set to arbitrary values, and they will appear
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properly during formatting. However, care must be taken that the symbols and strings
do not conflict, or parsing will be unreliable. For example, either the positive and
negative prefixes or the suffixes must be distinct for DecimalFormat.parse() to be able
to distinguish positive from negative values. (If they are identical, then DecimalFormat
will behave as if no negative subpattern was specified.) Another example is that the
decimal separator and thousands separator should be distinct characters, or parsing
will be impossible.

The grouping separator is commonly used for thousands, but in some coun-
tries it separates ten-thousands. The grouping size is a constant number of digits
between the grouping characters, such as 3 for 100,000,000 or 4 for 1,0000,0000. If
you supply a pattern with multiple grouping characters, the interval between the last

one and the end of the integer is the one that is used. So " #,## ##H#, #HHH#" ==

THAFHATAFHA == AHHHHFH
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Figure 3.16: Pop-up dialog for “X Bounds” item in the “Plot Control” menu.

X/Y Bounds A dialog like shown in Figure 3.16 will prompt the user with cus-

tomized values to fine tune the plot display.
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Figure 3.17: The radio button choices triggered by the “Legend Position” item in the

“Plot Control” menu.

Legend Position As shown in Figure 3.17, switching the position of the legend can

be achieved with one simple click.
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Figure 3.18: Pop-up dialog for the “Curves” item in the “Plot Control” menu.

Curves As shown in Figure 3.18, attributes of each curve (color, line property, and

symbol) can be individually adjusted through this dialog. A plot may contain multiple
curves, indexed starting 0. Only the curve of the selected index will have its attributes

updated.
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Figure 3.19: The “Eye Mode” menu.

The “Eye Mode” Menu

In modern digital applications, the quality of signal transmission from the driver to
the receiver is often characterized by an eye diagram. The menu “Eye Mode” provides
some basic facilities of converting a regular signal waveform into an eye diagram. The

following items are under this menu:

Define UI: will display a dialog, as shown in Figure 3.20, for user to enter a

value for the unit interval (UI) or bit-time.

Offset: will display a dialog, as shown in Figure 3.21, for user to enter a horizontal

offset for shifting the eye pattern.

Y ref: will promt for a reference (re-centering) Y value, as shown in Figure 3.22.

Generate Eye: trigger the generation of an eye diagram.
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Figure 3.20: Pop-up dialog for the “Define UI” item in the “Eye Mode” menu.

Dialog for eye offset value
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Figure 3.21: Pop-up dialog for the “Offset” item in the “Eye Mode” menu.
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Figure 3.22: Pop-up dialog for the “Y ref” item in the “Eye Mode” menu.
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An example waveform and its corresponding eye diagram is displayed in Fig-

ure 3.23 and 3.24, respectively.

e P =) |
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Figure 1
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= yeTest im0 warel — eye Test r0. wanv|

Figure 3.23: An example waveform which may be folded into an eye diagram.
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Figure 3.24: The eye diagram view of the waveform data.

The “Window” Menu

The “Window” menu provide the user a means of switching between the regular wave-

form and eye diagram views.

Waveform
Eye Diagram

Figure 3.25: The “Window” menu in a plot.
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3.2 Plotting Utility based on PtPlot
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Figure 3.26: A plot window based on the PtPlot package.

In the upper part of the plotter panel, there are three buttons:

e Original: will resume the plot to its original view.

e Configure: allow user to configure various properties of the plot, such as the

title, axis titles, ranges of X and Y axes.

e Zoom Fit: will automatically calculate the ranges and capture all data points.

The PtPlot plotter has several menu items under the File menu:

30



CHAPTER 3 — MANUSCRIPT

< Figure 1
File
Import XY Data
Save EPS
Save PNG
Export Text
Close

=TT R

Figure 3.27: The “File” menu of a PtPlot plot.

Import X Y Data: allows the user to import additional text file (organized in

two columns separated by white space) and overlay with the current plot.

Save EPS: generates an encapsulated PostScript file.

Save PNG: generates a file in the Portable Network Graphics format.

Export Text: exports the data points of the current plot to several two-column
X|Y data file in pure text format. User can transfer such data into other appli-

cation for further processing or plotting.

Close: will close the current plot window.
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Examples

4.1 Example 1: eyeTest.tr0

Selecting variables wavl and wav2 results in 4.1. In the pop-up plot window, use
pull-down menus under “Eye Mode” by selecting Ul=1.25e-9 and offset=0.45. Choose

“Generate Eye” results in Figure 4.2.
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Figure 4.1: Waveforms from Example 1.
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Figure 4.2: Eye diagram display of Example 1.
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4.2 Example 2: FilterA.ac0

Choose variables 1, 2, and 3 use “dB” filter:
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Choose Coloe || Log ¥ [JLog¥ | Set |

Figure 4.3: Example 2: three variables as a result of an AC simulation are plotted.
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4.3 Example 3: Monte.tr0O

Choose variable power and select traces associated with all the sweep variable points.

The overlapped traces are plotted below:
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Figure 4.4: Example 3: Variable ‘power’ from a Monte Carlo simulation with one sweep

parameter.
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4.4 Example 4: CorrDiffZ.tr0

Choose zdiff results in the following plot
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Figure 4.5: Example 4: A plot of simulated differential impedance.
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